Topics Topics Edit Profile Profile Help/Instructions Help Member List Member List  
Search Last 1|3|7 Days Search Search Tree View Tree View  

Mplab 8.00v build program without sho...

:: EPE Chat Zone ­:: ­Radio Bygones Message Board :: » EPE Chat Zone » Archive through 23 April, 2017 » Mplab 8.00v build program without show any error message « Previous Next »

  Thread Last Poster Posts Pages Last Post
  ClosedClosed: New threads not accepted on this page        

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

jamesron
Just joined
Username: jamesron

Post Number: 5
Registered: 02-2017

Rating: N/A
Votes: 0 (Vote!)

Posted on Tuesday, 14 February, 2017 - 01:42 pm:   Edit Post Delete Post Print Post    Move Post (Moderator/Admin Only)

After I build my Mplab program version 8.00, but failure to compiler my program, and there is no error message show after building.

Here's error message :

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files (x86)\Microchip\MPASM Suite\MPAsmWin.exe" /q /p16F690 "TUT1.ASM" /l"TUT1.lst" /e"TUT1.err" /o"TUT1.o"
Warning[215] C:\USERS\USER\DOCUMENTS\PIC\TUT1.ASM 2 : Processor superseded by command line. Verify processor symbol.
Executing: "C:\Program Files (x86)\Microchip\MPASM Suite\MPAsmWin.exe" /q /p16F690 "C:\Users\user\Documents\PIC\TUT4.ASM" /l"TUT4.lst" /e"TUT4.err" /o"TUT4.o"
Executing: "C:\Program Files (x86)\Microchip\MPASM Suite\MPAsmWin.exe" /q /p16F690 "TUT8.ASM" /l"TUT8.lst" /e"TUT8.err" /o"TUT8.o"
Message[302] C:\USERS\USER\DOCUMENTS\PIC\TUT8.ASM 19 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] C:\USERS\USER\DOCUMENTS\PIC\TUT8.ASM 22 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] C:\USERS\USER\DOCUMENTS\PIC\TUT8.ASM 25 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] C:\USERS\USER\DOCUMENTS\PIC\TUT8.ASM 30 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] C:\USERS\USER\DOCUMENTS\PIC\TUT8.ASM 33 : Register in operand not in bank 0. Ensure that bank bits are correct.
Skipping link step. The project contains no linker script.
BUILD FAILED: Tue Feb 14 21:35:59 2017
Top of pagePrevious messageNext messageBottom of page Link to this message

741
Frequent Contributor
Username: 741

Post Number: 874
Registered: 08-2005


Rating: N/A
Votes: 0 (Vote!)

Posted on Thursday, 16 February, 2017 - 09:27 pm:   Edit Post Delete Post Print Post    Move Post (Moderator/Admin Only)

Hi,

It looks like your issues are likely to be very similar to Processor superseded by command line and The project contains no linker script

i.e.
(1) The source has code has errors: Check
list p=16F690
include "p16F690.inc"

(2) Add a 'linker script' as suggested on the second link above.
Top of pagePrevious messageNext messageBottom of page Link to this message

bowden_p
Frequent Contributor
Username: bowden_p

Post Number: 561
Registered: 01-2006

Rating: N/A
Votes: 0 (Vote!)

Posted on Saturday, 18 February, 2017 - 11:02 pm:   Edit Post Delete Post Print Post    Move Post (Moderator/Admin Only)

Hi jamesron,
You might find updating to the last MPLAB version, ( MPLAB 8.92 ?) which may have a more helpful error output. If you are only compiling assembly code from your .asm file, without any pre-assembled code from a library for instance, I don't think you will need a linker script. Also if your project is for absolute code compilation, not relocatable, again no linker is needed.

All my coding is absolute, without any library input, and I have never needed to refer to a linker script. ( Maybe this is done automatically for me, however.)

I stand corrected if anyone knows differently !!

With regards, Paul.

(Message edited by bowden_p on 18 February, 2017)
Top of pagePrevious messageNext messageBottom of page Link to this message

jamesron
Member
Username: jamesron

Post Number: 6
Registered: 02-2017

Rating: N/A
Votes: 0 (Vote!)

Posted on Thursday, 23 February, 2017 - 02:13 am:   Edit Post Delete Post Print Post    Move Post (Moderator/Admin Only)

Thank you everyone,

Problems solve, Thank you.

Administration Administration Log Out Log Out   Previous Page Previous Page Next Page Next Page